Heartbleed bug
Date:11.04.2014 15:00:22
Author:Vin J.
You have probably heard of the Heartbleed bug (http://heartbleed.com/) that can be used to steal supposedly secured information through exploiting a vulnerability of OpenSSL certificates.
It is important to note that this security hole was available only on websites that used our shared SSL certificates. The websites using RapidSSL or SSL certificates from GeoTrust were not affected.
On few of our servers we were using the exploitable version of OpenSSL and as soon as a security patch was released by OpenSSL, we have installed it and re-issued all existing certificates. What this means is that all your websites and the details you submit over the shared SSL certificates are once again secure.
We want to thank you for choosing our sevices!
Latest News

News Archive